首页 站长快讯正文

在三层交换机中配置DHCP服务

admin 站长快讯 2022-11-17 14:11:32 1101 0

客户端IP地址的分发,我想是每个网络工程师都要面临的问题。因为只有客户端获取了合法的IP,他们才能在网络中进行通信。所以IP地址的分发,显得尤为重要。

关于IP地址的分发,有两种情况:

A. 静态地址分发--就是有管理员手动将客户端的网卡设置成指定的IP。

B. 动态地址分发--就是有DHCP服务器,自动下发IP地址给客户端。

本文内容主要介绍的是动态地址分发(DHCP)在三层交换机上的设置,网络设备为Cisco,平台为GNS3模拟器。

DHCP服务器与客户端client进行动态地址分发的步骤如下:

1. Client 发送DHCP Discover广播包 到目的地址255.255.255.255 、MAC地址FF-FF-FF-FF-FF-FF。

2. DHCP Server 回复 DHCP Offer包 ,并提供一个IP地址给到client。

3. Client发送DHCP Request 广播包,来应答使用这个IP地址,同时告知其他DHCP Server他们的Offers被拒绝。

4. DHCP server 回应一个DHCP Acknowledge包。

5. DHCP地址分发结束。

dhcp服务是什么_dhcp服务器实验报告_dhcp服务

下面我们就在模拟器中dhcp服务器实验报告,进行DHCP服务在三层交换机上的配置,拓扑图如下:

dhcp服务是什么_dhcp服务_dhcp服务器实验报告

AccessSW的配置:

1.将PC与交换机互联的端口,划分到相应vlan中

interface FastEthernet0/14

switchport access vlan 20

!

interface FastEthernet0/15

switchport access vlan 10

2. 将与核心交换机相连的端口设置为trunk模式,保证vlan数据可顺利通过

interface FastEthernet0/0

switchport mode trunk

这样AccessSW的配置就结束了。下面看一下CoreSwitch的配置。

CoreSwitch的配置:

1. 首先配置与AccessSW级联的端口Fa0/0

interface FastEthernet0/0

switchport mode trunk

End

2. 配置VLAN

interface Vlan10

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

3. 配置 DHCP地址池

CoreSwitch(config)#ip dhcp pool vlan10 -- 配置Vlan10的DHCP地址池

CoreSwitch(config)#network 192.168.10.0 255.255.255.0 -- 地址池中可分发的地址段

CoreSwitch(config)#default-router 192.168.10.1 -- 默认网关

CoreSwitch(config)#dns-server 8.8.8.8 -- DNS服务器地址 这里是8.8.8.8 ,可根据实际情况更改

CoreSwitch(config)# lease 8 -- 设置续约期限为8天,可根据实际情况更改

Vlan20的地址池配置方法一样。

ip dhcp pool vlan20

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

dns-server 8.8.8.8

lease 8

4. 除去需要保留或者特殊用途的地址,这里将各vlan的网关从地址池中拿出

CoreSwitch(config)#ip dhcp excluded-address 192.168.10.1

CoreSwitch(config)#ip dhcp excluded-address 192.168.20.1

这样CoreSwitch的配置也就结束了dhcp服务器实验报告,现在三层交换机就成为了DHCP服务器可以向客户端分发地址了。

效果:

PC1 可以获取到Vlan10中的地址:192.168.10.2

PC1> ip dhcp

DDORA IP 192.168.10.2/24 GW 192.168.10.1

PC1> sh ip

NAME: PC1[1]

IP/MASK: 192.168.10.2/24

GATEWAY: 192.168.10.1

DNS: 8.8.8.8

DHCP SERVER : 192.168.10.1

DHCP LEASE : 681273, 691200/345600/604800

MAC: 00:50:79:66:68:00

LPORT: 10010

RHOST:PORT : 127.0.0.1:10011

MTU:: 1500

PC2 可以获取到Vlan20中的地址:192.168.20.2

PC2> ip dhcp

DORA IP 192.168.20.2/24 GW 192.168.20.1

PC2> sh ip

NAME: PC2[1]

IP/MASK: 192.168.20.2/24

GATEWAY: 192.168.20.1

DNS: 8.8.8.8

DHCP SERVER : 192.168.20.1

DHCP LEASE : 691198, 691200/345600/604800

MAC: 00:50:79:66:68:01

LPORT: 10008

RHOST:PORT : 127.0.0.1:10009

MTU:: 1500

测试PC1和PC2 之间的通信:

PC1> ping 192.168.20.2

84 bytes from 192.168.20.2 icmp_seq=1 ttl=63 time=32.799 ms

84 bytes from 192.168.20.2 icmp_seq=2 ttl=63 time=31.272 ms

84 bytes from 192.168.20.2 icmp_seq=3 ttl=63 time=31.100 ms

84 bytes from 192.168.20.2 icmp_seq=4 ttl=63 time=30.963 ms

84 bytes from 192.168.20.2 icmp_seq=5 ttl=63 time=31.909 ms

至此,所有的配置都已经完成。我们可以抓包在看一下PC从DHCP服务器中获取IP的过程。

如下图所示,获取IP地址的过程和上文提到的一致,共4步。

dhcp服务器实验报告_dhcp服务_dhcp服务是什么

这里由于vlan的网关都设置在了三层交换机上,所以各Vlan的网关便可以理解为是DHCP服务器的IP地址。属于客户端和DHCP服务器在同一个网段内。

抓包如下:

dhcp服务器实验报告_dhcp服务是什么_dhcp服务

dhcp服务是什么_dhcp服务器实验报告_dhcp服务

如果你的DHCP服务器或者三层交换机与客户端不在同一网段,那么就需要开启DHCP中继再转发DHCP的请求报文给到DHCP服务器。

配置如下:

CoreSwitch(config)#int vlan 10

CoreSwitch(config-if)#ip helper-address x.x.x.x -- x.x.x.x为你的DHCP服务器的IP地址

这样DHCP服务器就可以跨网段的获取到客户端的请求报文了,就可以顺利下发IP地址了。

最后在向大家介绍一下如何在三层交换机里的DHCP服务中,怎样查看分配了多少地址给到客户端:

在全局模式下:键入 show ip dhcp binding , 即可以查看DHCP服务器下发了多少正在使用的IP地址,以及对应客户端的MAC地址和租约期等信息。

CoreSwitch#sh ip dhcp binding

Bindings from all pools not associated with VRF:

IP addressClient-ID/Hardware address/User name Lease expirationType

192.168.10.20100.5079.6668.00Mar 09 2002 10:07 AM Automatic

192.168.20.20100.5079.6668.01Mar 09 2002 10:00 AM Automatic

好了,讲到这里大家应该对怎样配置DHCP服务器在三层交换机上有所了解了,如果你的环境中有需要,快去试试吧。

打赏
三层交换机dhcp客户端服务器
版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。

发表评论

评论列表(0人评论 , 1101人围观)
☹还没有评论,来说两句吧...